查看: 173|回复: 4

3588安装RKNN的问题

[复制链接]

1

主题

2

帖子

7

积分

新手上路

Rank: 1

积分
7
发表于 2022-6-15 09:33:36 | 显示全部楼层 |阅读模式
固件安装的是官方提供的ubuntu20.0.4,参考网址:https://wiki.t-firefly.com/zh_CN/ROC-RK3588S-PC/usage_npu.html和文件Rockchip_Quick_Start_RKNN_SDK_V1.3.0_CN.pdf中的方法安装rknn,版本为rknntookit2.1.3.0,python是3.8,安装依赖文件时,一直报错:
ERROR: Could not find a version that satisfies the requirement tensorflow (from versions: none)
ERROR: No matching distribution found for tensorflow
这个文件是我去除了版本的,按照官方提供的文件onnx也找不到。
使用的是阿里云,pip也升级到了最新版本。

使用docker加载,使用docker images明明可以看到镜像,启动时却提示找不到本地镜像。




屏幕截图

屏幕截图
回复

使用道具 举报

398

主题

594

帖子

1万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
19761
发表于 2022-6-15 11:07:10 | 显示全部楼层
很多编译错误都可以google一下的,

建议参考一下:
https://blog.csdn.net/xavier_muse/article/details/83998744

看能不能解决你的问题

风火轮微信公众号
回复 支持 反对

使用道具 举报

16

主题

153

帖子

738

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
738
QQ
发表于 2022-6-15 11:49:21 | 显示全部楼层
它那是在电脑上运行转换模型,你在板子上转干啥子
回复 支持 反对

使用道具 举报

1

主题

2

帖子

7

积分

新手上路

Rank: 1

积分
7
 楼主| 发表于 2022-6-15 12:39:25 | 显示全部楼层
不能脱离PC单独在板子上推理么?
回复 支持 反对

使用道具 举报

16

主题

153

帖子

738

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
738
QQ
发表于 2022-6-15 13:42:44 | 显示全部楼层
风火轮用户OcP2C 发表于 2022-6-15 12:39
不能脱离PC单独在板子上推理么?

系统依赖:RKNN-Toolkit2 目前版本适用系统Ubuntu18.04(x64)及以上,工具只能安装在 PC 上,暂不支持 Windows、MacOS、Debian 等操作系统。fireflywiki上说的。你可以试着改,可能会出现需要装的依赖没有对应版本。

rknntookit2.1.3.0这个只是转换工具而已。只要是rknn格式可以直接在板子运行。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|风火轮WIKI|手机版|深圳风火轮团队 ( 粤ICP备17095099号 )

GMT+8, 2022-7-7 00:25 , Processed in 0.051232 second(s), 23 queries .

快速回复 返回顶部 返回列表
 
【客服1】 商务合作 15289193
【客服2】 业务洽谈 13257599
【客服3】 售前咨询 510313198
【邮箱】
smartfire@smartfire.cn